• Guys, we've spent considerable money converting the Les Paul Forum to this new XenForo platform, and we have ongoing monthly operating expenses. THE "DONATIONS" TAB IS NOW WORKING, AND WE WOULD APPRECIATE ANY DONATIONS YOU CAN MAKE TO KEEP THE LES PAUL FORUM GOING! Thank you!

Blockhead Firstborn

Jollyb

New member
Joined
Jan 3, 2021
Messages
11
I remember playing through one of these over a decade ago. Basically a cloned 18w Marshall Bluesbreaker type amp. Always wanted one.I got the chance to get one in a trade and jumped on it. Mine Is the 2x12 celestion blues model.

When I got it it was extremely noisy with single coils, and it hates pedals. Feedsback almost instantously . (Not in a good way) not the experience I remembered. I could have returned it, but I really want this circuit in my life.

Gonna start with the tubes . Two EL84 Output, EZ81 Rectifier, (3) ECC83 Preamp Tubes. Any other Suggestions if they don't do the trick?
 

el84ster

Active member
Joined
Sep 10, 2001
Messages
1,376
Hopefully new tubes will solve it, but after that it’s time for a tech if not. Might be some of the grounding has come loose or corroded.
Do you know if it’s been messed with? Sometimes well-intentioned mods go awry.
 

Jollyb

New member
Joined
Jan 3, 2021
Messages
11
Hopefully new tubes will solve it, but after that it’s time for a tech if not. Might be some of the grounding has come loose or corroded.
Do you know if it’s been messed with? Sometimes well-intentioned mods go awry.
I was told it was stock. It certainly appears to be in very good to Excellent condition. It could be a grounding issue for sure though. Luckily I live pretty close to Mark Kane , I'll see if I can get an appointment with him. Thanks!!
 

el84ster

Active member
Joined
Sep 10, 2001
Messages
1,376
There you go.
that circuit is just so good. The best distorted tone I’ve ever had in my life! That amp just begs to be turned up.
 

Jollyb

New member
Joined
Jan 3, 2021
Messages
11
No doubt. It kills with a tele and a Les Paul. I'll get ths one straight. Thanks!
 

Wally

Well-known member
Joined
Feb 27, 2003
Messages
3,293
you could try a 12AY7 in V1. If that is too much of a gain cut, try a 5751.
 

Jollyb

New member
Joined
Jan 3, 2021
Messages
11
I actually have a spare one.......it's at my Techs as we speak. He plugs it in and the thing played great! But he knew exactly where to tap it and it went bonkers.

He believes it just needs a good cleaning. It was sitting for a bit. Probably not in a A/C controlled environment. One input was definitely loose.

He will go through it for me and make it right.
 

Jollyb

New member
Joined
Jan 3, 2021
Messages
11
OK Got the amp back from Mark Kane yesterday. I'm thrilled!!! He traced the issues back to the trem circuit. It wasn't original and had been poorly replaced. Mark suggested a really fantastic mod that has transformed this amp!
The regular circuit , Volume and tone are untouched. He just cleaned it up some. The Trem circuit was modded with a master volume. The speed and intensity with a full tone circuit of Bass/Treble/and middle.
It sounds glorious! I havnt tried any pedals with it because I don't see the need. Boosting the Master you get this glorious Stonesy /Black Crows overdrive , cleans up really well with the guitars volume knob. I have a strat with a 25 db boost Clapton mod I'm going to try out later today. Really really pleased!
 

el84ster

Active member
Joined
Sep 10, 2001
Messages
1,376
Killer! I always liked the non-trem channel
more. Now it sounds like you have 2 killer channels.
yeah you don’t need pedals with that amp.
 
Top